New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Configuration: Answered

Topic does not exist loop on create

Whenever I try to create a new topic, either by jumping to a non-existing topic or via a create button, the topic is not created and I am again invited to create it. I'm now in Main web, no matter which web I started in. This happens in all webs.

The wiki requires a login to view via TemplateLogin and the ony scripts available without login are ResetPassword and Register.

I've set up a new web, HHG, and set this as the web in HomePage.

I've looked at logs, configure and preferences, but can't spot anything.

Please that I've made a common tyro mistake and point me in the right direction.


-- DavidRimmer - 09 May 2016

Are you possibly blocking cookies or javascript in your browser?

-- GeorgeClark - 09 May 2016

I do block third party cookies. Chromium has cookies FOSWIKISID and FOSWIKISTRIKEONE.

I can browse a working page which uses javascript to change images.

-- DavidRimmer - 10 May 2016

It's hard to say what's going on. Could your server be redirecting request, for example a misconfigured rewrite rule? Sometimes a silent redirecting can break foswiki without obvious symptoms during viewing. Carefully watch the browser Net debugging to see if you are getting redirects that you don't expect.

-- GeorgeClark - 11 May 2016

Spot on.

Removing the rewrite suggested by Awardspace in sorted it.


-- DavidRimmer - 12 May 2016

QuestionForm edit

Subject Configuration
Version Foswiki 2.1.2
Status Answered
Related Topics
Topic revision: r7 - 13 May 2016, DavidRimmer - This page was cached on 11 Mar 2018 - 10:57.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License