cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Using an extension: Answered

Text on Webpage is not displayed

Hello Everybody,

I hope someone can help me.

I have Installed NatSkin on my Foswiki and the edit Text will not displayed. (See attachment).

I have no Idea what could be the Problem and I hope there is someone in the hole WWW who can help my or give me a hint.

with kind regards

Wübbo

-- WuebboFreese - 24 Mar 2014

Seems you've got a VIEW_TEMPLATE in place, maybe in your user profile.

-- MichaelDaum - 24 Mar 2014

Ok nice to know, thanks a lot. But where can I find these settings, it is not in Main/SitePreferences. I would be glad if you can help me.

-- WuebboFreese - 25 Mar 2014

And also in the System/WebHome I see the Text but not in System/ReferenceManual. Are there different Templates?

-- WuebboFreese - 25 Mar 2014

The VIEW_TEMPLATE is a normal preference setting. A very common error is that users add a VIEW_TEMPLATE to their user profile page ... which then is applied to any topic of the site when logged in as this user. Same error can happein when setting a VIEW_TEMPLATE in WebPreferences or SitePreferences.

To check if this is actually causing the error, try appending ?template=view to the URL. This will override any preference setting stored in your user profile, WebPreferences, SitePreferences, session object, or AutoTemplatePlugin rules as configured in your LocalSite.cfg

-- MichaelDaum - 25 Mar 2014

Ok, I guess we are on the right way.

With the appending of ?template=view to the URL I got the text with the following Error:

IIF{ "$DISPLAYCOMMENTS='on' and $COMMENTFORMAT!='insidetab' and not context save and not context preview and not context edit" then="$percntTMPL:P{\"comments::system::metacomment\"}$percnt" }

Also did I made a Screenshot of the AutoTemplatePlugin and AutoViewTemplatePlugin of the configure page.

-- WuebboFreese - 25 Mar 2014

OK I get it. I found that other users didn't had this problem. so I got in my useradmin.txt file and delete the row: META:PREFERENCE{name="VIEW_TEMPLATE" title="VIEW_TEMPLATE" type="Set" value="GroupView"}

I had no Idea what tis means but no it works.

Thanks a lot MichaelDaum

-- WuebboFreese - 25 Mar 2014
 

QuestionForm edit

Subject Using an extension
Extension NatSkin
Version Foswiki 1.1.2
Status Answered
Related Topics
Topic attachments
I Attachment Action Size Date Who Comment
AutoTemplate_settings.pngpng AutoTemplate_settings.png manage 102 K 25 Mar 2014 - 10:22 WuebboFreese  
AutoViewTemplate_settings.pngpng AutoViewTemplate_settings.png manage 84 K 25 Mar 2014 - 10:22 WuebboFreese  
Empty_Topic.jpgjpg Empty_Topic.jpg manage 194 K 24 Mar 2014 - 16:30 WuebboFreese  
Wikitext_Topic.jpgjpg Wikitext_Topic.jpg manage 315 K 24 Mar 2014 - 16:31 WuebboFreese  
Topic revision: r6 - 25 Mar 2014, WuebboFreese - This page was cached on 22 Aug 2018 - 00:48.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy