This question about Using an extension: Answered

perl modules needed

I was trying to use TwistyPlugin with foswiki 1.1.2. After decompressing it at foswiki root directory, I got it installed but disabled. At the error.log file, I could get the message: Can't locate version.pm in @INC

This server runs in a linux centos 5 box. Looking for this perl module, it returned me perl-version. So I installed but another problem occurred: Can't locate auto/main/version/declare.al in @INC

But this time, there is no perl-module or whatever yum package to install. What could have gone wrong here ?

-- BernardoCosta - 20 Mar 2014

Foswiki since 1.1.6 requires an up-to-date version 0.77 or newer. See http://foswiki.org/System/ReleaseNotes01x01#Module_version_strings_and_new_module_dependency_in_1.1.6_and_1.1.7

version-.077 first shipped with perl v5.10.1

As far as errors with declare.al, I'm not familiar with that issue. I didn't see any hits at all for that particular error in google. I don't think foswiki uses anything like that. Maybe there is something wrong with the centos perl-version package.You might try installing version using cpan.

-- GeorgeClark - 21 Mar 2014

One other note, I did install the latest TwistyPlugin on a Foswiki 1.1.2 / Perl 5.8.8 system (not Centos though) using version 0.9901. Foswiki Twisties are working correctly. I'm not sure what else to suggest. "declare.al" is not mentioned in Foswiki, so this seems to be something internal to the Perl module.

-- GeorgeClark - 21 Mar 2014

You can also check if your package upgrade installed the correct version:
perl -Mversion -e 'print "$version::VERSION\n"'

And finally, you could change the new version of TwistyPlugin.pm to remove the dependency. Edit the file lib/Foswiki/Plugins/TwistyPlugin.pm and remove the line marked here with a -, replacing it with the line marked + (but don't include the - or +),.

- use version; our $VERSION = version->declare("v1.6.18");
+ our $VERSION = 'v1.6.18';

-- GeorgeClark - 21 Mar 2014

Well, it looks like centos 5 is far outdated with its perl version packages. I am only using the base/updates and epel repositories. Maybe the best for me is try to upgrade to centos 6 or use another perl version compiled from scratch.
$ perl -Mversion -e 'print "$version::VERSION\n"'
0.7203
I can also try to purge version package from TwistyPlugin as you have said. I just wonder what will happen when I do it.

-- BernardoCosta - 24 Mar 2014

I looks like removing version package from TwistyPlugin have enabled the plugin in InstalledPlugins. I'll just do some tests on it to see if things are working as they should.

-- BernardoCosta - 24 Mar 2014

See also Tasks.Item12583

-- MichaelDaum - 24 Mar 2014

Removing version from the package is completely safe on old Foswiki.

-- GeorgeClark - 24 Mar 2014
 

QuestionForm edit

Subject Using an extension
Extension TwistyPlugin
Version Foswiki 1.1.2
Status Answered
Related Topics
Topic revision: r6 - 24 Mar 2014, GeorgeClark - This page was cached on 13 Jan 2018 - 12:47.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License