This question about Configuration: Asked

How can I check if mod_perl is working on my apache server on debian

Hello everybody,

We are trying to improve the performance of our foswiki server. But I think mod_perl on our Apache2 on Debian isn't working.

I have installed the following software components: I have added the following lines to our apache VirtualHost configuration:
PerlSwitches -wT
PerlRequire "/var/www/foswiki/tools/mod_perl_startup.pl"

when I execute ps --user www-data on the shell right after opening or editing a topic, there are of course a few apache2 processes shown and processes like "view" and "edit". I think this is a sign, that mod_perl isn't working.

In the foswiki configuration => Web server environment => mod_perl is following text shown:
Not used for this script (correct). mod_perl may be enabled for the other scripts. You can check this by visiting System.WebHome in your wiki.
mod_perl is not loaded into Apache

I have read somewhere, that the configuration script has to be excluded from loading with mod_perl. But where can I check, if mod_perl is working in the System.WebHome? Should there the following string change to another value?

This site is running Foswiki version v1.1.6, Release Foswiki-1.1.6, Plugin API version 2.2

What should I do next?

-- KlausReithmaier - 18 Feb 2013

 

QuestionForm edit

Subject Configuration
Extension ModPerlEngineContrib
Version Foswiki 1.1.6
Status Asked
Related Topics
Topic revision: r1 - 18 Feb 2013, KlausReithmaier - This page was cached on 18 Oct 2018 - 02:35.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy