This question about Installation of Foswiki: Answered

RPM dependency problems 1.1.5 -> 1.1.6 ("Requires: foswiki-patchfoswikicontrib" , but foswiki-patchfoswikicontrib doesn't exist)

This is a new Foswiki installation. I installed Foswiki 1.1.5 using the Yum/RPM repo at fosiki.org . The installation has not been heavily customized.

Now, I want to upgrade from 1.1.5 to 1.1.6 . However, yum is complaining about a missing dependency of 'foswiki-patchfoswikicontrib' for my plugins.

# yum update
Loaded plugins: changelog, downloadonly, fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: linux.mirrors.es.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package foswiki.noarch 0:1.1.5-279 will be updated
---> Package foswiki.noarch 0:1.1.6-279 will be an update
---> Package foswiki-autoviewtemplateplugin.noarch 0:120411-279 will be updated
---> Package foswiki-autoviewtemplateplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-autoviewtemplateplugin-121203-279.noarch
---> Package foswiki-commentplugin.noarch 0:120411-279 will be updated
---> Package foswiki-commentplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-commentplugin-121203-279.noarch
---> Package foswiki-comparerevisionsaddon.noarch 0:120411-279 will be updated
---> Package foswiki-comparerevisionsaddon.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-comparerevisionsaddon-121203-279.noarch
---> Package foswiki-core.noarch 0:1.1.5-279 will be updated
---> Package foswiki-core.noarch 0:1.1.6-279 will be an update
---> Package foswiki-edittableplugin.noarch 0:120411-279 will be updated
---> Package foswiki-edittableplugin.noarch 0:121203-279 will be an update
---> Package foswiki-emptyplugin.noarch 0:120411-279 will be updated
---> Package foswiki-emptyplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-emptyplugin-121203-279.noarch
---> Package foswiki-famfamfamcontrib.noarch 0:120411-279 will be updated
---> Package foswiki-famfamfamcontrib.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-famfamfamcontrib-121203-279.noarch
---> Package foswiki-historyplugin.noarch 0:120411-279 will be updated
---> Package foswiki-historyplugin.noarch 0:121203-279 will be an update
---> Package foswiki-interwikiplugin.noarch 0:120411-279 will be updated
---> Package foswiki-interwikiplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-interwikiplugin-121203-279.noarch
---> Package foswiki-jqueryplugin.noarch 0:120717-279 will be updated
---> Package foswiki-jqueryplugin.noarch 0:121203-279 will be an update
---> Package foswiki-jscalendarcontrib.noarch 0:120411-279 will be updated
---> Package foswiki-jscalendarcontrib.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-jscalendarcontrib-121203-279.noarch
---> Package foswiki-mailercontrib.noarch 0:120922-279 will be updated
---> Package foswiki-mailercontrib.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-mailercontrib-121203-279.noarch
---> Package foswiki-patternskin.noarch 0:120411-279 will be updated
---> Package foswiki-patternskin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-patternskin-121203-279.noarch
---> Package foswiki-preferencesplugin.noarch 0:120411-279 will be updated
---> Package foswiki-preferencesplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-preferencesplugin-121203-279.noarch
---> Package foswiki-renderlistplugin.noarch 0:120411-279 will be updated
---> Package foswiki-renderlistplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-renderlistplugin-121203-279.noarch
---> Package foswiki-slideshowplugin.noarch 0:120411-279 will be updated
---> Package foswiki-slideshowplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-slideshowplugin-121203-279.noarch
---> Package foswiki-smiliesplugin.noarch 0:120411-279 will be updated
---> Package foswiki-smiliesplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-smiliesplugin-121203-279.noarch
---> Package foswiki-spreadsheetplugin.noarch 0:120411-279 will be updated
---> Package foswiki-spreadsheetplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-spreadsheetplugin-121203-279.noarch
---> Package foswiki-tableplugin.noarch 0:120411-279 will be updated
---> Package foswiki-tableplugin.noarch 0:121203-279 will be an update
---> Package foswiki-tinymceplugin.noarch 0:120523-279 will be updated
---> Package foswiki-tinymceplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-tinymceplugin-121203-279.noarch
---> Package foswiki-tipscontrib.noarch 0:120411-279 will be updated
---> Package foswiki-tipscontrib.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-tipscontrib-121203-279.noarch
---> Package foswiki-topicusermappingcontrib.noarch 0:120411-279 will be updated
---> Package foswiki-topicusermappingcontrib.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-topicusermappingcontrib-121203-279.noarch
---> Package foswiki-twistyplugin.noarch 0:120411-279 will be updated
---> Package foswiki-twistyplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-twistyplugin-121203-279.noarch
---> Package foswiki-wysiwygplugin.noarch 0:120606-279 will be updated
---> Package foswiki-wysiwygplugin.noarch 0:121203-279 will be an update
--> Processing Dependency: foswiki-patchfoswikicontrib for package: foswiki-wysiwygplugin-121203-279.noarch
--> Finished Dependency Resolution
Error: Package: foswiki-slideshowplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-tinymceplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-commentplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-topicusermappingcontrib-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-wysiwygplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-jscalendarcontrib-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-spreadsheetplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-comparerevisionsaddon-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-emptyplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-interwikiplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-autoviewtemplateplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-tipscontrib-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-renderlistplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-famfamfamcontrib-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-mailercontrib-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-twistyplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-preferencesplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-smiliesplugin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
Error: Package: foswiki-patternskin-121203-279.noarch (foswiki)
 Requires: foswiki-patchfoswikicontrib
 You could try using --skip-broken to work around the problem

However, no such RPM named 'foswiki-patchfoswikicontrib' exists at the Repo:

# yum search foswiki-patchfoswikicontrib
Loaded plugins: changelog, downloadonly, fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: linux.mirrors.es.net
Warning: No matches found for: foswiki-patchfoswikicontrib
No Matches found
# yum info foswiki-patchfoswikicontrib\*
Loaded plugins: changelog, downloadonly, fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: linux.mirrors.es.net
Error: No matching Packages to list
#

-- StefanLasiewski - 19 Dec 2012

sorry,

I've had some serious costs shock wrt my power bill, and turned off the servers that build those packages. I'll turn them back on tonite and see what I can do about it.

-- SvenDowideit - 20 Dec 2012

Last report was that the required dependencies had been built.

-- GeorgeClark - 21 Dec 2012
 

QuestionForm edit

Subject Installation of Foswiki
Extension
Version Foswiki 1.1.5
Status Answered
Related Topics
Topic revision: r3 - 21 Dec 2012, GeorgeClark - This page was cached on 12 Nov 2018 - 10:59.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy