cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Installation of Foswiki: Answered

Apache+mod_perl installation does not work

I have an Apache + mod_perl installation (or Apache2 + mod_perl2 installation) and when doing a vanilla install and configuration of Foswiki, I am missing files that are being referred to in the install documentation (e.g. mod_perl_startup.pl), and my error.log complains that it cannot find Foswiki/Engine/Apache.pm

Fix: an Apache+mod_perl installation requires ModPerlEngineContrib extention

Download the extention here: http://foswiki.org/Extensions/ModPerlEngineContrib

Extract the contents into your Foswiki installation directory. This extention contains the files you need.

-- Reported by chrsiv on irc

Added an entry to Tasks so we won't forget to update the documentation.

-- OlivierRaginel - 02 Apr 2009

(moved some comments on the task to Tasks.Item1412, which is where I had intended to add my comment) -- IsaacLin - 02 Apr 2009

QuestionForm edit

Subject Installation of Foswiki
Extension ModPerlEngineContrib
Version
Status Answered
Topic revision: r5 - 02 Apr 2009, IsaacLin - This page was cached on 23 Mar 2018 - 04:02.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License