Next step: Download and unpack the Foswiki distribution
Up: Overview

Installing Foswiki: verify system requirements

Foswiki is capable of running on a variety of operating systems and supporting a wide range of browsers, due to its minimal client and server requirements.

Server requirements

Perl 5.8.8 or higher.

Web server with capabilities comparable to Apache. See InstallingOnSpecificPlatforms for other supported web servers.

Optional dependencies

RCS 5.7 or higher and GNU diff 2.7 or higher. If you do not have RCS or GNU diff available, you can use a pure Perl implementation included with Foswiki, called RcsLite (at the cost of performance). If you are not using the GNU diff program bundled with your RCS installation, you must use the same GNU diff version that RCS uses.

fgrep and egrep are used for searching when the search algorithm is set to Foswiki::Store::SearchAlgorithms::Forking (see the step "Configure Foswiki" for more information).

cron or other scheduler to schedule maintenance tasks.

Required CPAN modules

With Perl 5.8.8 and higher, you do not need to install any additional CPAN modules.

Modules to install with Perl 5.8.7:

Module Preferred version
CGI Upgrade to any version >=3.15 except for version 3.37

Modules to install with Perl 5.8.4, 5.8.5, 5.8.6:

Module Preferred version
CGI Upgrade to any version >=3.15 except for version 3.37
Cwd Upgrade to any version >=3.05
File::Spec Upgrade to any version >=3.05
Time::Local Upgrade to any version >=1.11

See Foswiki:Support.HowToInstallCpanModules for detailed information on how to install any CPAN libraries not present in your installation.

You can check version numbers from the command line (replace "ModuleName" with the name of the module):

perl -e 'use ModuleName; print $ModuleName::VERSION."\n"' 

Optional CPAN modules

The following Perl modules may be used by Foswiki. See Foswiki:Support.HowToInstallCpanModules for detailed information on how to install CPAN libraries.

Module Preferred version Description
Archive::Tar   May be required by the Extensions Installer in configure if command line tar or unzip is not available
CGI::Cookie >=1.24 Used for session support
Digest::base    
Digest::SHA    
Locale::Maketext::Lexicon >=0 Used for I18N support
Net::SMTP >=2.29 Used for sending mail
URI   Used for configure

Most of these modules will probably already be present in your installation. You can check version numbers with the configure script, or if you're still trying to get to that point, check from the command line (replace "ModuleName" with the name of the module):

perl -e 'use ModuleName; print $ModuleName::VERSION."\n"' 

Next step: Download and unpack the Foswiki distribution
Up: Overview

  • Set IGVariant =

Customized versions of InstallStepSystemRequirements:

Topic revision: r7 - 05 Jan 2014, GeorgeClark - This page was cached on 09 Jan 2018 - 11:38.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License