This question about Using an extension: Answered

EditTemplate is not taken while creating a topic for the first time

Hey folks!

I defined a view and edit template for a specific web in order to get the description line from my data form displayed. So in normal view and edit mode the autoviewtemplateplugin is doing his job just fine. All data is displayed with the extra column description I added.

Now: When creating a topic for the first time via a formtemplate the attached data form appears as foswiki standard not taking in mind the edittemplate I defined for it!

Topic is created via this link ... bin/edit/RohstoffWiki/RSAUTOINC0001?templatetopic=RohStoffTemplate;formtemplate=RohstoffForm;topicparent=RohstoffDatenbank.

I tried attaching the data form directly to the template topic or switching the Autoviewtemplateplugin from mode "exist" to "section" to especially define when to use the edittemplate but both did not work.

How can I get foswiki to use my edittemplate also while creating a topic for the very first time? Any help or hint in the right direction would be highly appreciated!

-- PaulHahler - 23 Aug 2010

Given your DataForm is called MyDataForm and your edit template is MyDataEditTemplate, add a template url parameter like in ...bin/edit/RohstoffWiki/...?....;template=MyDataEdit

Unfortunately, AutoViewTemplatePlugin isn't able to derive the edit_template during create time. So you have to add the template url param manually at this point.

-- MichaelDaum - 23 Aug 2010

This has been fixed in AutoTemplatePlugin here.

-- Main.MichaelDaum - 18 Oct 2015

QuestionForm edit

Subject Using an extension
Extension AutoViewTemplatePlugin
Version Foswiki 1.0.9
Status Answered
Related Topics
Topic revision: r3 - 18 Oct 2015, MichaelDaum - This page was cached on 22 Sep 2017 - 01:27.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License