This question about Installation of Foswiki: Answered

Mod_perl in Foswiki 2.0.0

Dear Foswiki developers, could you be so kind and tell me what does it mean that mod_perl is now working "out of the box"? Does it mean that regardless of script-handler set in Apache configuration, mod_perl will be used? Or does it mean that no Perl startup script is required?

-- MateuszKDzior - 22 Jul 2015

It means that the ModPerlEngineContrib is now bundled as part of the Foswiki-2.0.0.tzg file. On prior versions of Foswiki, you needed to first install and fully configure Foswiki as a CGI application, then use the extensions installer to download and install ModPerlEngineContrib, and finally re-configure the server and Foswiki for mod_perl.

On Foswiki 2.0, you can configure your apache for mod_perl, and then proceed with foswiki bootstrap. Any configuration of script handlers, etc. still needs to be done.

-- GeorgeClark - 22 Jul 2015
 

QuestionForm edit

Subject Installation of Foswiki
Extension ModPerlEngineContrib
Version Foswiki 2.0.0
Status Answered
Related Topics
Topic revision: r2 - 22 Jul 2015, GeorgeClark - This page was cached on 23 Aug 2017 - 16:16.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License