This question about Using an extension: Answered

Upgrading from JQuery 4.91 to current fails

-- DonSlife - 20 May 2015

/bin/configure does not show the extension as needing updated, even though my version is from 2013.

jquery problem.PNG

When I upgrade another package that requires JQuery > 6, the log shows the upgrade failing during the pre-install.

[root@p-itsec-wk01 configure]# cat JQueryPlugin-20150520-143038-Install.log
Installing JQueryPlugin
Dependency Report for JQueryPlugin ...
===== INSTALLED =======
JSON version 2.53 loaded



Creating Backup of JQueryPlugin ...
Backup saved into /var/www/foswiki/working/configure/backup/JQueryPlugin-backup-20150520-103038
   Archived as /var/www/foswiki/working/configure/backup/JQueryPlugin-backup-20150520-103038.tgz

Running Pre-install exit for JQueryPlugin ...

Installing from the command line also hangs, but I was able to just download the tarball and install it by hand.,

-- DonSlife - 20 May 2015

There are a couple of issues. The failure to show the update is a bug in configure on 1.1.9, along with a change to how some packages are configured. The install failure is probably a server timeout. JQueryPlugin doesn't have a Pre-install exit. I just tested the install locally on a new 1.1.9 system, and the install did work, but it takes a very long time - 5-10 minutes. That bug was identified and fixed in the upcoming 1.2.0. There are still some cases where the install runs too long, but it still should be much faster on most systems.

-- GeorgeClark - 21 May 2015
 

QuestionForm edit

Subject Using an extension
Extension JQueryPlugin
Version Foswiki 1.1.9
Status Answered
Related Topics
Topic attachments
I Attachment Action Size Date Who Comment
jquery_problem.PNGPNG jquery_problem.PNG manage 26 K 20 May 2015 - 15:37 DonSlife  
Topic revision: r3 - 21 May 2015, GeorgeClark - This page was cached on 25 May 2017 - 14:39.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License