This question about Using an extension: Answered

Dependency on deprecated Any::Moose module

I'm busy trying to configure SolrPlugin, and waiting while Any::Moose and it's incredible number of dependencies installs. Checking CPAN, I see that the developpers have deprecated Any::Moose and discourage its use. Should I be concerned?

-- JacobEtches - 10 Feb 2015

Same as always: the ever moving sands of web-development. CPAN:WebService::Solr depends on CPAN:Any::Moose. So as long as we didn't fix the former, we need to use the latter as well. CPAN:MooX::late outlines what to do with WebService::Solr ...

There is a bug report already: https://rt.cpan.org/Public/Bug/Display.html?id=96977

Unless that issue has been addressed - which is not the case in 0.23 yet - will we stick with Any::Moose as well.

-- MichaelDaum - 27 Feb 2015
 

QuestionForm edit

Subject Using an extension
Extension SolrPlugin
Version Foswiki 1.1.9
Status Answered
Related Topics
Topic revision: r2 - 27 Feb 2015, MichaelDaum - This page was cached on 24 Aug 2017 - 01:33.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License