This question about Using an extension: Answered

Perl dependency for SolrSearch

When I installed SolrPlugin using the configure tool, I got a list of additional Perl modules that were required:
File::MMagic
Spreadsheet::ParseExcel
Spreadsheet::XLSX

It appears that SolrSearch also requires Moose.pm which were not listed.

The documentation and output from configure's install script need to be updated.

-- VickiBrown - 10 Jul 2012

Please try to use SolrPlugin from trunk: see http://svn.foswiki.org/trunk/SolrPlugin

Above extra packages are dependencies of StringifierContrib and no direct dependencies of SolrPlugin itself.

Moose is already listed now in http://svn.foswiki.org/trunk/SolrPlugin/lib/Foswiki/Plugins/SolrPlugin/DEPENDENCIES

-- MichaelDaum - 10 Jul 2012

  1. My level of expertise is not at the "use from trunk" level.
  2. My reason for installibg SolrPLugin is to help a client and there's no way I'm telling a client that they need to use unpublished, unreleased software straight out of SVN.
  3. What is StringifierContrib? I did not install that, so why do I see its errors? Anything that gets installed with a plugin is a dependency of the plugin I installed.
  4. I need to be able to hand this to a client. I cannot tell a client "you need to dig into SVN and that's not really a dependency for this extension; it just prevents this extension from working.

-- VickiBrown - 11 Jul 2012

Try latest version. Issues have been addressed.

-- MichaelDaum - 11 Sep 2015
 

QuestionForm edit

Subject Using an extension
Extension SolrPlugin
Version
Status Answered
Related Topics
Topic revision: r4 - 11 Sep 2015, MichaelDaum - This page was cached on 22 Aug 2017 - 21:52.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License