Feature Proposal: Deprecate ApacheHtpasswd Module

Motivation

its ancient and we don't maintain it well enough to keep releasing it

Description and Documentation

in 1.2.0 deprecate it by adding a deprecation message into configure, and possible by using the UpdatesPlugin message functionality

then in 2.0, make that module a shim that loads HtPasswdUser, and then in 2.2, remove it entirely

Examples

Impact

%WHATDOESITAFFECT%
edit

Implementation

-- Contributors: SvenDowideit - 19 Sep 2012

Discussion

Do it. It was only ever there as a demonstrator.

-- CrawfordCurrie - 19 Sep 2012

From Foswiki 1.1.3 and on, the PasswordManager checker has had a warning recommending that ApacheHtpasswdUser not be used. So hopefully deprecation would not be a surprise.

-- GeorgeClark - 19 Sep 2012
 
Topic revision: r7 - 08 Jul 2015, MichaelDaum - This page was cached on 28 Sep 2016 - 12:28.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License